Ford Mustang Forums banner
starting problem
1-5 of 5 Results
  1. Electrical & Wiring
    In a recent haste to hook up a temporary battery on my 1987 LX, I accidentally hooked up the terminals backwards. I know.... Upon doing this, the starter solenoid immediately emitted a puff of smoke. I have since pulled the battery, verified that it works and charged it. I've also replaced the...
  2. General Mustang Tech
    Hello guys, An 8 month 1995 cobra 347 engine rebuild project that's almost complete..except i couldn't get it to start yesterday :/ I'm not sure if any of these additions cause the problem with the timing/SCT chip. I've added the following; Ed's custom cam Lower/upper intake from cobra intake...
  3. 5.0/5.8 Engine Tech
    Ok guys, I got a problem w/ my 89 GT. Here's the details... 89 GT, was an AOD car, was swapped out to a Tremec 3550 before I got it. Still has the A9P computer in it. The A/C was removed and a Vortech S trim put in. MSD box/Distributor/Coil, AFR 185's, and a "supercharger" cam. The car...
  4. 5.0/5.8 Engine Tech
    Hi Folks! I have an engine starting question that maybe others have experienced. When I turn the key to crank the engine, it turns over fine. However, it doesn't start. However the moment I release the key from the crank position, the engine starts right up. Once started, the engine runs...
  5. GT & SOHC
    OK, broke a shift fork, took the tranny and stock h-pipe off. 2 plugs on the tranny, 4 o2 sensors. put the tranny back in, with a new shifter. hooked up the 6 plugs. took the converters off the h-pipe. car started and ran fine. shut it off, started it and moved it to make sure the shifter/clutch...
1-5 of 5 Results
Top