Ford Mustang Forums banner

rich

  1. 5.0/5.8 Engine Tech
    Hey everyone, Long time lurker, first time poster. ive got two mustangs, an 88 lx and a 1990 lx. both 5.0s with the 88 being manual and the 90 auto. ever since ive bought these cars theyve both had problems running at low rpms under load. what seems to happen is the idle will be rough, once you...
  2. 5.0/5.8 Engine Tech
    ok my mustang has a misfire from 1600 rpm to 2000rpm when you hold the throttle while driving or in neutral it kind of sounds like a pop/stutter every second or two but very quiet you half to try to be listing to hear it/feel it you can feel/hear it also when driving ive used a set of 24 pound...
  3. 5.0/5.8 Engine Tech
    so another problem with the mustang its running really really rich where it makes your eyes burn and the only way to start it is to give it alot of throttle after 5 seconds or cranking it also has a high idle. the first startup its fine then if you turn it off and try to start it it will be...
  4. GT & SOHC
    just did a pi swap. my car idled fine on the start up but then on decelleration i get a shuttering sound coming from my exaust. also the car stalled once when i came to a stop. also i checked plugs and all of the plugs on my pass side are black and the ones on my drivers side look normal or a...
  5. GT & SOHC
    did the swap car runs great untill a few minutes then it idles up and down then shuts off. i did a coolant flush then it got a little better. i have it all timed right under the cover. i used a timing gun light to check timing on the front cover and the timing mark for tdc on my steeda crank...
  6. 5.0/5.8 Engine Tech
    ok here is the rundown, just bought the car and am trying to tune it . this is what i have been told and what i can verify so far. 86 GT 302 trickflow heads f-cam victor jr intake 1.7 roller rockers full msd ignition (dist,6al,blaster 2 coil) 4.10 gears tremec 3550 holley 750 dp carb (4779)...
  7. 94/95 Tech
    My 94 gt is running rich, and came out of nowhere. Changed plugs and MAF runs great but still tons of raw gas smell and some smoke. Car ran perfect and then ran terrible. Regulator is showing to be holding at 40 psi with the 24lb injectors,,,so im firing, but fuel is loading up. HELP?:curses:
Top