Ford Mustang Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-6 of 6 Results
  1. GT & SOHC
    Had battery disconnected while I worked on it for a couple of weeks. When I turn key, I hear the fuel pump prime; and when key is in 'ON' position, NO theft light. However it behaves exactly like a PATS issue. It starts and immediately shuts off. Any ideas? Thanks
  2. SVT & DOHC
    Hi. I’m at a loss as to next step. It starts and runs for a second or so, so I think my PATS is ok, but not 100%. So my fuel pressure seems low, 20-30 psi, this all started when the fuel filter leaned it out 10 psi. My son limped it home after changing the fuel filter, but that only got us 20-30...
  3. GT & SOHC
    So I'm having just a little bit of trouble diagnosing what is wrong with my 04 GT. I pulled my motor out and rebuilt it, and also did a battery relocation to the trunk. Everything is back together and I can't get it to start! Before tear down the car worked fine, but now, as soon as I connect...
  4. SVT & DOHC
    Over the weekend I installed a steering column from a 98 Cobra in my 96 Cobra. I transferred over the key/ignition from the 96 so I was surprised to see it won't run and the theft light flashed rapidly. Any thoughts if this is something I can resolve at home of it will require a tow to the...
  5. General Mustang Tech
    95 Mustang GT convertible with automatic transmission. My owner's manual says it "disables the starting circuit" when anti-theft system is activated. I had the engine rebuilt and I took out the engine wiring harness to recover them. When trying to start the engine it just turns over and...
  6. 94/95 Tech
    I recently removed the engine out of the my 95 5.0L GT (automatic transmission) convertible and got it rebuilt. I also took the engine wiring harness out and covered the majority of wires. Once I feel like I have had everything buttoned up I seem to have starting problems. At first I thought I...
1-6 of 6 Results
Top